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Enter data manually 
 

 
Enter text or a number in a cell 

1. On the worksheet, click a cell. 

2. Type the numbers or text that you want to enter, and then press ENTER or TAB. 

To enter data on a new line within a cell, enter a line break by pressing ALT+ENTER. 

Enter a number that has a fixed decimal point 

1. On the File tab, click Options. 

2. Click Advanced, and then under Editing options, select the Automatically insert a decimal point check box. 

3. In the Places box, enter a positive number for digits to the right of the decimal point or a negative number for 

digits to the left of the decimal point. 

For example, if you enter 3 in the Places box and then type 2834 in a cell, the value will appear as 2.834. If you 

enter -3 in the Places box and then type 283, the value will be 283000. 

4. On the worksheet, click a cell, and then enter the number that you want. 

Data that you typed in cells before selecting the Fixed decimal option is not affected. 

To temporarily override the Fixed decimal option, type a decimal point when you enter the number. 

Enter a date or a time in a cell 

1. On the worksheet, click a cell. 

2. Type a date or time as follows: 

▪ To enter a date, use a slash mark or a hyphen to separate the parts of a date; for example, 

type 9/5/2002 or 5-Sep-2002. 

▪ To enter a time that is based on the 12-hour clock, enter the time followed by a space, and then 

type a or p after the time; for example, 9:00 p. Otherwise, Excel enters the time as AM. 

To enter the current date and time, press Ctrl+Shift+; (semicolon). 

▪ To enter a date or time that stays current when you reopen a worksheet, you can use 

the TODAY and NOW functions. 

▪ When you enter a date or a time in a cell, it appears either in the default date or time format for your computer or 
in the format that was applied to the cell before you entered the date or time. The default date or time format is 
based on the date and time settings in the Regional and Language Options dialog box (Control Panel, Clock, 
Language, and Region). If these settings on your computer have been changed, the dates and times in your 
workbooks that have not been formatted by using the Format Cells command are displayed according to those 
settings. 

▪ To apply the default date or time format, click the cell that contains the date or time value, and then press 
Ctrl+Shift+# or Ctrl+Shift+@. 

 

 

https://support.microsoft.com/en-us/office/today-function-5eb3078d-a82c-4736-8930-2f51a028fdd9
https://support.microsoft.com/en-us/office/now-function-3337fd29-145a-4347-b2e6-20c904739c46
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Enter the same data into several cells at the same time 

1. Select the cells into which you want to enter the same data. The cells do not have to be adjacent. 

2. In the active cell, type the data, and then press Ctrl+Enter. 

You can also enter the same data into several cells by using the fill handle  to automatically fill data in worksheet 

cells. 

For more information, see the article Fill data automatically in worksheet cells. 

 

Enter the same data on several worksheets at the same time 

By making multiple worksheets active at the same time, you can enter new data or change existing data on one of the 

worksheets, and the changes are applied to the same cells on all the selected worksheets. 

1. Click the tab of the first worksheet that contains the data that you want to edit. Then hold down Ctrl while you click 

the tabs of other worksheets in which you want to synchronize the data. 

 

Note: If you don't see the tab of the worksheet that you want, click the tab scrolling buttons to find the worksheet, and 

then click its tab. If you still can't find the worksheet tabs that you want, you might have to maximize the document 

window. 

2. On the active worksheet, select the cell or range in which you want to edit existing or enter new data. 

3. In the active cell, type new data or edit the existing data, and then press Enter or Tab to move the selection to the 

next cell. 

The changes are applied to all the worksheets that you selected. 

4. Repeat the previous step until you have completed entering or editing data. 

▪ To cancel a selection of multiple worksheets, click any unselected worksheet. If an unselected worksheet is not 

visible, you can right-click the tab of a selected worksheet, and then click Ungroup Sheets. 

▪ When you enter or edit data, the changes affect all the selected worksheets and can inadvertently replace data 

that you didn't mean to change. To help avoid this, you can view all the worksheets at the same time to identify 

potential data conflicts. 

a. On the View tab, in the Window group, click New Window. 

b. Switch to the new window, and then click a worksheet that you want to view. 

c. Repeat steps 1 and 2 for each worksheet that you want to view. 

d. On the View tab, in the Window group, click Arrange All, and then click the option that you want. 

e. To view worksheets in the active workbook only, in the Arrange Windows dialog box, select 

the Windows of active workbook check box. 

https://support.microsoft.com/en-us/office/fill-data-automatically-in-worksheet-cells-74e31bdd-d993-45da-aa82-35a236c5b5db


  

 

            Updated 01.22.2021  ISD Service Desk 714.509.4457   3 of 13    

Microsoft Resources 

Excel 
 

 
 

Format Data 

Adjust worksheet settings and cell formats 

There are several settings in Excel that you can change to help make manual data entry easier. Some changes affect all 

workbooks, some affect the whole worksheet, and some affect only the cells that you specify. 

Change the direction for the Enter key 

When you press Tab to enter data in several cells in a row and then press Enter at the end of that row, by default, the 

selection moves to the start of the next row. 

Pressing Enter moves the selection down one cell, and pressing Tab moves the selection one cell to the right. You cannot 

change the direction of the move for the Tab key, but you can specify a different direction for the Enter key. Changing this 

setting affects the whole worksheet, any other open worksheets, any other open workbooks, and all new workbooks. 

1. On the File tab, click Options. 

2. In the Advanced category, under Editing options, select the After pressing Enter, move selection check box, 

and then click the direction that you want in the Direction box. 

Change the width of a column 

At times, a cell might display #####. This can occur when the cell contains a number or a date and the width of its column 

cannot display all the characters that its format requires. For example, suppose a cell with the Date format "mm/dd/yyyy" 

contains 12/31/2015. However, the column is only wide enough to display six characters. The cell will display #####. To 

see the entire contents of the cell with its current format, you must increase the width of the column. 

1. Click the cell for which you want to change the column width. 

2. On the Home tab, in the Cells group, click Format. 

 

3. Under Cell Size, do one of the following: 

▪ To fit all text in the cell, click AutoFit Column Width. 

▪ To specify a larger column width, click Column Width, and then type the width that you want in 

the Column width box. 

Note: As an alternative to increasing the width of a column, you can change the format of that column or even an 

individual cell. For example, you could change the date format so that a date is displayed as only the month and day 

("mm/dd" format), such as 12/31, or represent a number in a Scientific (exponential) format, such as 4E+08. 
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Wrap text in a cell 

You can display multiple lines of text inside a cell by wrapping the text. Wrapping text in a cell does not affect other cells. 

 

1. Click the cell in which you want to wrap the text. 

2. On the Home tab, in the Alignment group, click Wrap Text. 

 

Note: If the text is a long word, the characters won't wrap (the word won't be split); instead, you can widen the column or 
decrease the font size to see all the text. If all the text is not visible after you wrap the text, you might have to adjust the 
height of the row. On the Home tab, in the Cells group, click Format, and then under Cell Size click AutoFit Row. 
For more information on wrapping text, see the article Wrap text in a cell. 

Change the format of a number 

In Excel, the format of a cell is separate from the data that is stored in the cell. This display difference can have a 
significant effect when the data is numeric. For example, when a number that you enter is rounded, usually only the 
displayed number is rounded. Calculations use the actual number that is stored in the cell, not the formatted number that 
is displayed. Hence, calculations might appear inaccurate because of rounding in one or more cells. 
After you type numbers in a cell, you can change the format in which they are displayed. 

1. Click the cell that contains the numbers that you want to format. 

2. On the Home tab, in the Number group, click the arrow next to the Number Format box, and then click the 

format that you want. 

 

To select a number format from the list of available formats, click More Number Formats, and then click the format that 
you want to use in the Category list. 
Format a number as text 

For numbers that should not be calculated in Excel, such as phone numbers, you can format them as text by applying the 
Text format to empty cells before typing the numbers. 

1. Select an empty cell. 

2. On the Home tab, in the Number group, click the arrow next to the Number Format box, and then click Text. 

 

3. Type the numbers that you want in the formatted cell. 

Numbers that you entered before you applied the Text format to the cells must be entered again in the formatted cells. To 
quickly reenter numbers as text, select each cell, press F2, and then press Enter. 
  

https://support.microsoft.com/en-us/office/wrap-text-in-a-cell-2a18cff5-ccc1-4bce-95e4-f0d4f3ff4e84
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Fill data automatically 
 

 

Use the Auto Fill feature to fill cells with data that follows a pattern or are based on data in other cells. 

1. Select one or more cells you want to use as a basis for filling additional cells. 

For a series like 1, 2, 3, 4, 5..., type 1 and 2 in the first two cells. For the series 2, 4, 6, 8..., type 2 and 4. 

For the series 2, 2, 2, 2..., type 2 in first cell only. 

2. Drag the fill handle  . 

3. If needed, click Auto Fill Options    and choose the option you want. 

 
  

Move or copy cells and cell contents 
 

 
Use Cut, Copy, and Paste to move or copy cell contents. Or copy specific contents or attributes from the cells. For 

example, copy the resulting value of a formula without copying the formula, or copy only the formula. 

When you move or copy a cell, Excel moves or copies the cell, including formulas and their resulting values, cell formats, 

and comments. 

You can move cells in Excel by drag and dropping or using the Cut and Paste commands. 

Move cells by drag and dropping 

1. Select the cells or range of cells that you want to move or copy. 

2. Point to the border of the selection. 

3. When the pointer becomes a move pointer  , drag the cell or range of cells to another location. 

Move cells by using Cut and Paste 

1. Select a cell or a cell range. 

2. Select Home > Cut  or press Ctrl + X. 

3. Select a cell where you want to move the data. 

4. Select Home > Paste  or press Ctrl + V. 

Copy cells in your worksheet using the Copy and Paste commands. 

1. Select the cell or range of cells. 

2. Select Copy or press Ctrl + C. 

3. Select Paste or press Ctrl + V. 
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Move or copy just the contents of a cell 

1. Double-click the cell that contains the data that you want to move or copy. 

Note    By default, you can edit and select cell data directly in the cell by double-clicking it, but you can also edit 

and select cell data in the formula bar. 

2. In the cell, select the characters that you want to move or copy. 

3. On the Home tab, in the Clipboard group, do one of the following: 

 

▪ To move the selection, click Cut  . 

Keyboard shortcut     You can also press Ctrl+X. 

▪ To copy the selection, click Copy  . 

Keyboard shortcut     You can also press Ctrl+C. 

4. In the cell, click where you want to paste the characters, or double-click another cell to move or copy the data. 

5. On the Home tab, in the Clipboard group, click Paste  . 

Keyboard shortcut     You can also press Ctrl+V. 

6. Press ENTER. 

Note: When you double-click a cell or press F2 to edit the active cell, the arrow keys work only within that cell. To use the 

arrow keys to move to another cell, first press Enter to complete your editing changes to the active cell. 
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Copy cell values, cell formats, or formulas only 

When you paste copied data, you can do any of the following: 

▪ Paste only the cell formatting, such as font color or fill color (and not the contents of the cells). 
▪ Convert any formulas in the cell to the calculated values without overwriting the existing formatting. 
▪ Paste only the formulas (and not the calculated values). 
▪ Select the cell or range of cells that contains the values, cell formats, or formulas that you want to copy. 

▪ On the Home tab, in the Clipboard group, click Copy  . 

 

Keyboard shortcut     You can also press Ctrl+C. 

▪ Select the upper-left cell of the paste area or the cell where you want to paste the value, cell format, or formula. 

▪ On the Home tab, in the Clipboard group, click the arrow below Paste  , and then do one of the following: 

▪ To paste values only, click Values. 

▪ To paste cell formats only, click Formatting. 

▪ To paste formulas only, click Formulas. 

Note: If the copied formulas contain relative cell references, Excel adjusts the references (and the relative parts of mixed 
cell references) in the duplicate formulas. For example, suppose that cell B8 contains the formula =SUM(B1:B7). If you 
copy the formula to cell C8, the duplicate formula refers to the corresponding cells in that column: =SUM(C1:C7). If the 
copied formulas contain absolute cell references, the references in the duplicate formulas are not changed. If you do not 
get the results that you want, you can also change the references in the original formulas to either relative or absolute cell 
references and then recopy the cells. 

Copy cell width settings 

When you paste copied data, the pasted data uses the column width settings of the target cells. To correct the column 
widths so that they match the source cells, follow these steps. 

1. Select the cells that you want to move or copy. 
How to select cells or ranges 

2. On the Home tab, in the Clipboard group, do one of the following: 

 

▪ To move cells, click Cut  . 

Keyboard shortcut     You can also press Ctrl+X. 

▪ To copy cells, click Copy  . 

Keyboard shortcut     You can also press Ctrl+C. 
3. Select the upper-left cell of the paste area. 

Tip: To move or copy a selection to a different worksheet or workbook, click another worksheet tab or switch to another 
workbook, and then select the upper-left cell of the paste area. 

4. On the Home tab, in the Clipboard group, click the arrow under Paste  , and then click Keep Source 

Column Widths. 
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Format numbers 
 

 
Apply number formats such as dates, currency, or fractions to cells in a worksheet. For example,  f you’re work ng on your 

quarterly budget, you can use the Currency number format so your numbers represent money. Or, if you have a column 

of dates, you can specify that you want the dates to appear as March 14, 2012, 14-Mar-12, or 3/14. 

Follow these steps to format numbers: 

1. Select the cells containing the numbers you need to format. 

2. Select CTRL+1. 

On a Mac, select Control+1, or Command+1. 

3. In the window that displays, select the Number tab (skip this step if you're using Office for the web). 

4. Select a Category option, and then select specific formatting changes on the right. 

 

Tip: Do you have numbers show ng up  n your cells as #####  Th s probably means your cell  sn’t w de enough to show 

the whole number. Try double-clicking the right border of the column that contains the cells with #####. This will change 

the column width and row height to fit the number. You can also drag the right border of the column to make it any size 

you want. 

  

https://support.microsoft.com/en-us/office/change-the-column-width-and-row-height-72f5e3cc-994d-43e8-ae58-9774a0905f46
https://support.microsoft.com/en-us/office/change-the-column-width-and-row-height-72f5e3cc-994d-43e8-ae58-9774a0905f46
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Stop your numbers from automatically formatting 

Sometimes if you enter numbers into a cell—or import them from another data source—Excel doesn't format them as you 

expect. If, for example, you type a number along with a slash mark (/) or a hyphen (-), Excel might apply a Date format. 

You can prevent this automatic number formatting by applying the Text format to the cells. 

It's easy to do: 

1. Select the cells that contain numbers you don't want Excel to automatically format. 

2. Select CTRL+1. 

On a Mac, select Control+1, or Command+1. 

3. On the Number tab, select Text in the Category list. 
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Apply or remove cell borders 
 

 

Apply a predefined cell border 

1. On a worksheet, select the cell or range of cells that you want to add a border to, change the border style on, or 

remove a border from. 

2. On the Home tab, in the Font group, do one of the following: 

▪ To apply a new or different border style, click the arrow next to Borders  , and then click a border 

style. 

Tip: To apply a custom border style or a diagonal border, click More Borders. In the Format Cells dialog box, on 

the Border tab, under Line and Color, click the line style and color that you want. Under Presets and Border, click one 

or more buttons to indicate the border placement. Two diagonal border buttons     are available under Border. 

▪ To remove cell borders, click the arrow next to Borders  , and then click No Border  . 

▪ The Borders button displays the most recently used border style. You can click the Borders button (not the 
arrow) to apply that style. 

▪ If you apply a border to a selected cell, the border is also applied to adjacent cells that share a bordered cell 
boundary. For example, if you apply a box border to enclose the range B1:C5, the cells D1:D5 acquire a left 
border. 

▪ If you apply two different types of borders to a shared cell boundary, the most recently applied border is 
displayed. 

▪ A selected range of cells is formatted as a single block of cells. If you apply a right border to the range of cells 
B1:C5, the border is displayed only on the right edge of the cells C1:C5. 

▪ If you want to print the same border on cells that are separated by a page break, but the border appears on only 
one page, you can apply an inside border. This way, you can print a border at the bottom of the last row of one 
page and use the same border at the top of the first row on the next page. Do the following: 

a. Select the rows on both sides of the page break. 

b. Click the arrow next to Borders  , and then click More Borders. 

c. Under Presets, click the Inside button  . 

d. Under Border, in the preview diagram, remove the vertical border by clicking it. 

 

Remove a cell border 

1. On a worksheet, select the cell or range of cells that you want to remove a border from. 

To cancel a selection of cells, click any cell on the worksheet. 

2. On the Home tab, in the Font group, click the arrow next to Borders  , and then click No Border  . 

--OR-- 

Click Home > the Borders arrow > Erase Border, and then select the cells with the border you want to erase. 

 

https://support.microsoft.com/en-us/office/select-cell-contents-in-excel-23f64223-2b6b-453a-8688-248355f10fa9
https://support.microsoft.com/en-us/office/select-cell-contents-in-excel-23f64223-2b6b-453a-8688-248355f10fa9
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Create a custom cell border style 
You can create a cell style that includes a custom border, and then you can apply that cell style when you want to display 
the custom border around selected cells. 

1. On the Home tab, in the Styles group, click Cell Styles.  
2. Click New Cell Style. 

 

3. In the Style name box, type an appropriate name for the new cell style. 
4. Click Format. 
5. On the Border tab, under Line, in the Style box, click the line style that you want to use for the border. 

 

6. In the Color box, select the color that you want to use. 
7. Under Border, click the border buttons to create the border that you want to use. 

8. Click OK. 

9. In the Style dialog box, under Style Includes (By Example), clear the check boxes for any formatting that you do 
not want to include in the cell style. 

10. Click OK. 
11. To apply the cell style, do the following: 

a. Select the cells that you want to format with the custom cell border. 
b. On the Home tab, in the Styles group, click Cell Styles. 
c. Click the custom cell style that you just created. Like 

the FancyBorderStyle button in this picture. 

https://support.microsoft.com/en-us/office/select-cell-contents-in-excel-23f64223-2b6b-453a-8688-248355f10fa9
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Hide or Unhide worksheets 
 

 
You can hide any worksheet to remove it from view. The data in hidden worksheets is not visible, but it can still be 

referenced from other worksheets and workbooks, and you can easily unhide hidden worksheets as needed. 

1. Right-click the sheet tab you want to hide, or any visible sheet if you want to unhide sheets. 

2. On the menu that appears, do one of the following: 

▪ To hide the sheet, select Hide. 

▪ To unhide hidden sheets, select them in the Unhide dialog that appears, and then select OK.  

 

Notes: To select multiple sheets do either of these: 

▪ Press and hold CTRL, then click the items to select them. 

▪ Press and hold SHIFT, then use the up and down arrow keys to adjust your selection. 
  

Hide or show rows or columns 
 

 
Hide columns 

1. Select one or more columns, and then press Ctrl to select additional columns that aren't adjacent. 

2. Right-click the selected columns, and then select Hide. 

Note: The double line between two columns is an indicator that you've hidden a column. 

Unhide columns 

1. Select the adjacent columns for the hidden columns. 

2. Right-click the selected columns, and then select Unhide. 

    Or double-click the double line between the two columns where hidden columns exist. 
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Insert or delete rows, and columns 
 

 
Insert or delete a column 

1. Select any cell within the column, then go to Home > Insert > Insert Sheet Columns or Delete Sheet Columns. 

2. Alternatively, right-click the top of the column, and then select Insert or Delete.  

Insert or delete a row 

1. Select any cell within the row, then go to Home > Insert > Insert Sheet Rows or Delete Sheet Rows. 

2. Alternatively, right-click the row number, and then select Insert or Delete. 

Formatting options 

When you select a row or column that has formatting applied, that formatting will be transferred to a new row or column 

that you insert. If you don't want the formatting to be applied, you can select the Insert Options button after you insert, 

and choose from one of the options as follows: 

 

If the Insert Options button isn't visible, then go to File > Options > Advanced > in the Cut, copy and paste group, 

check the Show Insert Options buttons option. 

 
Cl ck to watch the “Insert or delete rows, and columns” v deo. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
For more information, please refer to the Microsoft training resource page HERE 

https://www.microsoft.com/en-us/videoplayer/embed/RWfvNh?pid=ocpVideo0-innerdiv-oneplayer&postJsllMsg=true&maskLevel=20&market=en-us
https://www.microsoft.com/en-us/videoplayer/embed/RWfvNh?pid=ocpVideo0-innerdiv-oneplayer&postJsllMsg=true&maskLevel=20&market=en-us
https://support.microsoft.com/en-us/office/video-what-is-microsoft-teams-422bf3aa-9ae8-46f1-83a2-e65720e1a34d?wt.mc_id=otc_microsoft_teams

