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Tables 
 

 
Overview of Excel tables 

To make managing and analyzing a group of related data easier, you can turn a range of cells into an Excel table  

 

A table can include the following elements: 

▪ Header row    By default, a table has a header row. Every table column has filtering enabled in the header row so 

that you can filter or sort your table data quickly.  

 

You can turn off the header row in a table. For more information, see Turn Excel table headers on or off. 

▪ Banded rows    Alternate shading or banding in rows helps to better distinguish the data. 

 

https://support.microsoft.com/en-us/office/turn-excel-table-headers-on-or-off-c91d1742-312c-4480-820f-cf4b534c8b3b
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▪ Calculated columns    By entering a formula in one cell in a table column, you can create a calculated column in 

which that formula is instantly applied to all other cells in that table column

 

▪ Total row    Once you add a total row to a table, Excel gives you an AutoSum drop-down list to select from 

functions such as SUM, AVERAGE, and so on. When you select one of these options, the table will automatically 

convert them to a SUBTOTAL function, which will ignore rows that have been hidden with a filter by default. If you 

want to include hidden rows in your calculations, you can change the SUBTOTAL function arguments. 

 

▪ Sizing handle    A sizing handle in the lower-right corner of the table allows you to drag the table to the size that 

you want. 

 

https://support.microsoft.com/en-us/office/subtotal-function-7b027003-f060-4ade-9040-e478765b9939
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Create and format tables 

You can create as many tables as you want in a spreadsheet. 

To quickly create a table in Excel, do the following: 

1. Select the cell or the range in the data. 

2. Select Home > Format as Table. 

3. Pick a table style. 

4. In the Format as Table dialog box, select the checkbox next to My table as headers if you want the first row of 

the range to be the header row, and then click OK. 

 

Cl ck to watch the “Create and format tables” v deo. 

 

Copy a Word table into Excel 

When you want to move data from a Word table to Excel, you can avoid having to retype that data by copying it from 

Word directly. When you copy data from a Word table into an Excel worksheet, the data in each Word table cell is pasted 

in an individual cell on the worksheet. 

1. In a Word document, select the rows and columns of the table that you want to copy to an Excel worksheet. Make 

sure there aren't any extra carriage returns in the cells of the table, otherwise this may cause extra rows in Excel.  

2. To copy the selection, press CTRL+C. 

3. In the Excel worksheet, select the upper-left corner of the worksheet area where you want to paste the Word 

table. 

Note: Make sure that the paste area is empty before you paste the data. Data in Word table cells will replace any 

existing data in worksheet cells in the paste area. If necessary, review the table first in Word to verify its 

dimensions. 

4. Press CRL+V. 

5. To adjust the formatting, click Paste Options  next to the data that you pasted, and then do the following: 

▪ To use the formatting that is applied to the worksheet cells, click Match Destination Formatting. 

▪ To use the formatting of the Word table, click Keep Source Formatting. 

Note: Excel pastes the contents of each Word table cell into a single cell. After you paste the data, you can 

distribute the data across additional cells in a column (for example, to divide first and last names so that they 

appear in separate cells) by using the Text to Columns command. 

 

 

 

https://www.microsoft.com/en-us/videoplayer/embed/RWfBNc?pid=ocpVideo0-innerdiv-oneplayer&postJsllMsg=true&maskLevel=20&market=en-us
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Format an Excel table 

Excel provides numerous predefined table styles that you can use to quickly format a table. If the predefined table styles 

don't meet your needs, you can create and apply a custom table style. Although you can delete only custom table styles, 

you can remove any predefined table style so that it is no longer applied to a table. 

 

You can further adjust the table formatting by choosing Quick Styles options for table elements, such 

as Header and Total Rows, First and Last Columns, Banded Rows and Columns, as well as Auto Filtering. 

Note: The screen shots in this article were taken in Excel 2016. If you have a different version your view might be slightly 

different, but unless otherwise noted, the functionality is the same. 

 

Choose a table style 

When you have a data range that is not formatted as a table, Excel will automatically convert it to a table when you select 

a table style. You can also change the format for an existing table by selecting a different format. 

1. Select any cell within the table, or range of cells you want to format as a table. 

2. On the Home tab, click Format as Table. 
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3. Click the table style that you want to use. 

Notes:  

▪ Auto Preview - Excel will automatically format your data range or table with a preview of any style you select, but 

will only apply that style if you press Enter or click with the mouse to confirm it. You can scroll through the table 

formats with the mouse or your keyboard's arrow keys. 

▪ When you use Format as Table, Excel automatically converts your data range to a table. If you don't want to 

work with your data in a table, you can convert the table back to a regular range while keeping the table style 

formatting that you applied. For more information, see Convert an Excel table to a range of data. 

 

Create a custom table style 

1. Select any cell in the table you want to use to create a custom style. 

2. On the Home tab, click Format as Table, or expand the Table Styles gallery from the Table Tools > Design tab 

(the Table tab on a Mac). 

3. Click New Table Style, which will launch the New Table Style dialog. 

 

4. In the Name box, type a name for the new table style. 

5. In the Table Element box, do one of the following: 

▪ To format an element, click the element, then click Format, and then select the formatting options you 

want from the Font, Border or Fill tabs. 

▪ To remove existing formatting from an element, click the element, and then click Clear. 

6. Under Preview, you can see how the formatting changes that you made affect the table. 

7. To use the new table style as the default table style in the current workbook, select the Set as default table style 

for this document check box. 

 

https://support.microsoft.com/en-us/office/convert-an-excel-table-to-a-range-of-data-0b326ff1-1764-4ebe-84ea-786265d41c77
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Delete a custom table style 

1. Select any cell in the table from which you want to delete the custom table style. 

2. On the Home tab, click Format as Table, or expand the Table Styles gallery from the Table Tools > Design tab 

(the Table tab on a Mac). 

3. Under Custom, right-click the table style that you want to delete, and then click Delete on the shortcut menu. 

Note: All tables in the current workbook that are using that table style will be displayed in the default table format. 

 

Remove a table style 

1. Select any cell in the table from which you want to remove the current table style. 

2. On the Home tab, click Format as Table, or expand the Table Styles gallery from the Table Tools > Design tab 

(the Table tab on a Mac). 

3. Click Clear. 

The table will be displayed in the default table format. 

Note: Removing a table style does not remove the table. If you don't want to work with your data in a table, you 

can convert the table to a regular range.  

 

Choose table style options to format the table elements 

There are several table style options that can be toggled on and off. To apply any of these options: 

1. Select any cell in the table. 

2. Go to Table Tools > Design, or the Table tab on a Mac, and in the Table Style Options group, check or 

uncheck any of the following: 

 

▪ Header Row - Apply or remove formatting from the first row in the table. 
▪ Total Row - Quickly add SUBTOTAL functions like SUM, AVERAGE, COUNT, MIN/MAX to your table 

from a drop-down selection. SUBTOTAL functions allow you to include or ignore hidden rows in 
calculations. 

▪ First Column - Apply or remove formatting from the first column in the table. 
▪ Last Column - Apply or remove formatting from the last column in the table. 
▪ Banded Rows - Display odd and even rows with alternating shading for ease of reading. 
▪ Banded Columns - Display odd and even columns with alternating shading for ease of reading. 
▪ Filter Button - Toggle AutoFilter on and off. 

https://support.microsoft.com/en-us/office/subtotal-function-7b027003-f060-4ade-9040-e478765b9939
https://support.microsoft.com/en-us/office/filter-data-in-a-range-or-table-01832226-31b5-4568-8806-38c37dcc180e
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Resize a table by adding or removing rows and columns 

After you create an Excel table in your worksheet, you can easily add or remove table rows and columns. 

You can use the Resize command in Excel to add rows and columns to a table: 

1. Click anywhere in the table, and the Table Tools option appears. 

2. Click Design > Resize Table. 

 

3. Select the entire range of cells you want your table to include, starting with the upper-leftmost cell. 

In the example shown below, the original table covers the range A1:C5. After resizing to add two columns and three rows, 

the table will cover the range A1:E8. 

 

Tip: You can also click Collapse Dialog  to temporarily hide the Resize Table dialog box, select the range on the 

worksheet, and then click Expand dialog  . 
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Delete rows or columns in a table 

1. Select one or more table rows or table columns that you want to delete. 

You can also just select one or more cells in the table rows or table columns that you want to delete. 

2. On the Home tab, in the Cells group, click the arrow next to Delete, and then click Delete Table Rows or Delete 

Table Columns. 

 

You can also right-click one or more rows or columns, point to Delete on the shortcut menu, and then click Table 

Columns or Table Rows. Or you can right-click one or more cells in a table row or table column, point to Delete, and 

then click Table Rows or Table Columns. 

 

Remove duplicate rows from a table 

Just as you can remove duplicates from any selected data in Excel, you can easily remove duplicates from a table. 

1. Click anywhere in the table. 

This displays the Table Tools, adding the Design tab. 

2. On the Design tab, in the Tools group, click Remove Duplicates. 

 

3. In the Remove Duplicates dialog box, under Columns, select the columns that contain duplicates that you want 

to remove. 

You can also click Unselect All and then select the columns that you want or click Select All to select all of the 

columns. 

 

Remove blank rows from a table 

1. Make sure that the active cell is in a table column. 

2. Click the arrow  in the column header. 

3. To filter for blanks, in the AutoFilter menu at the top of the list of values, clear (Select All), and then at the bottom 

of the list of values, select (Blanks). 

4. Select the blank rows in the table, and then press CTRL+- (hyphen). 

You can use a similar procedure for filtering and removing blank worksheet rows.  
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Use calculated columns in an Excel table 

Create a calculated column 

1. Create a table. If you're not familiar with Excel tables, you can learn more at: Overview of Excel tables. 
2. Insert a new column into the table. You can do this by typing in the column immediately to the right of the table, 

and Excel will automatically extend the table for you. In this example, we created a new column by typing "Grand 
Total" into cell D1. 

 

Tips:  
▪ You can also add a table column from the Home tab. Just click on the 

arrow for Insert > Insert Table Columns to the Left. 
 

3. Type the formula that you want to use, and press Enter. 

 

In this case we entered =sum(, then selected the Qtr 1 and Qtr 2 columns. As a result, Excel built the 

formula: =SUM(Table1[@[Qtr 1]:[Qtr 2]]). This is called a structured reference formula, which is unique to Excel tables. 

The structured reference format is what allows the table to use the same formula for each row. A regular Excel formula for 

this would be =SUM(B2:C2), which you would then need to copy or fill down to the rest of the cells in your column 

 
4. When you press Enter, the formula is automatically filled into all cells of the column — above as well as below the 

cell where you entered the formula. The formula is the same for each row, but since it's a structured reference, 
Excel knows internally which row is which. 

 

  

https://support.microsoft.com/en-us/office/overview-of-excel-tables-7ab0bb7d-3a9e-4b56-a3c9-6c94334e492c
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Sort and Filter 
 

 
Sort text 

1. Select a cell in the column you want to sort. 

2. On the Data tab, in the Sort & Filter group, do one of the following: 

▪ To quick sort in ascending order, click  (Sort A to Z). 

▪ To quick sort in descending order, click  (Sort Z to A). 

Notes: Potential Issues 

▪ Check that all data is stored as text    If the column that you want to sort contains numbers stored as numbers 
and numbers stored as text, you need to format them all as either numbers or text. If you do not apply this format, 
the numbers stored as numbers are sorted before the numbers stored as text. To format all the selected data as 
text, Press Ctrl+1 to launch the Format Cells dialog, click the Number tab and then, under Category, 
click General, Number, or Text. 

▪ Remove any leading spaces    In some cases, data imported from another application might have leading 
spaces inserted before data. Remove the leading spaces before you sort the data. You can do this manually, or 
you can use the TRIM function. 

Sort numbers 

1. Select a cell in the column you want to sort. 

2. On the Data tab, in the Sort & Filter group, do one of the following: 

▪ To sort from low to high, click  (Sort Smallest to Largest). 

▪ To sort from high to low, click  (Sort Largest to Smallest). 

Notes:  

▪ Check that all numbers are stored as numbers    If the results are not what you expected, the column might 
contain numbers stored as text instead of as numbers. For example, negative numbers imported from some 
accounting systems, or a number entered with a leading apostrophe (') are stored as text.  

Sort dates or times 

1. Select a cell in the column you want to sort. 

2. On the Data tab, in the Sort & Filter group, do one of the following: 

▪ To sort from an earlier to a later date or time, click  (Sort Oldest to Newest). 

▪ To sort from a later to an earlier date or time, click  (Sort Newest to Oldest) 

Notes: Potential Issue    
▪ Check that dates and times are stored as dates or times    If the results are not what you expected, the 

column might contain dates or times stored as text instead of as dates or times. For Excel to sort dates and 
times correctly, all dates and times in a column must be stored as a date or time serial number. If Excel 
cannot recognize a value as a date or time, the date or time is stored as text.  

▪ If you want to sort by days of the week, format the cells to show the day of the week. If you want to sort by the 
day of the week regardless of the date, convert them to text by using the TEXT function. However, the TEXT 
function returns a text value, so the sort operation would be based on alphanumeric data.  

https://support.microsoft.com/en-us/office/trim-function-410388fa-c5df-49c6-b16c-9e5630b479f9
https://support.microsoft.com/en-us/office/text-function-20d5ac4d-7b94-49fd-bb38-93d29371225c
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Sort by more than one column or row 

You may want to sort by more than one column or row when you have data that you want to group by the same value in 
one column or row, and then sort another column or row within that group of equal values. For example, if you have a 
Department column and an Employee column, you can first sort by Department (to group all the employees in the same 
department together), and then sort by name (to put the names in alphabetical order within each department). You can 
sort by up to 64 columns. 

1. Select any cell in the data range. 

 

2. On the Data tab, in the Sort & Filter group, click Sort. 

 

3. In the Sort dialog box, under Column, in the Sort by box, select the first column that you want to sort. 

 

4. Under Sort On, select the type of sort. Do one of the following: 

▪ To sort by text, number, or date and time, select Values. 
▪ To sort by format, select Cell Color, Font Color, or Cell Icon. 

5. Under Order, select how you want to sort. Do one of the following: 

▪ For text values, select A to Z or Z to A. 
▪ For number values, select Smallest to Largest or Largest to Smallest. 
▪ For date or time values, select Oldest to Newest or Newest to Oldest. 
▪ To sort based on a custom list, select Custom List. 

6. To add another column to sort by, click Add Level, and then repeat steps three through five. 
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7. To copy a column to sort by, select the entry and then click Copy Level. 
8. To delete a column to sort by, select the entry and then click Delete Level. 

Note: You must keep at least one entry in the list. 
9. To change the order in which the columns are sorted, select an entry and then click the Up or Down arrow next to 

the Options button to change the order. 
Entries higher in the list are sorted before entries lower in the list. 

Sort by cell color, font color, or icon 

If you have manually or conditionally formatted a range of cells or a table column by cell color or font color, you can also 

sort by these colors. You can also sort by an icon set that you created with conditional formatting. 

1. Select a cell in the column you want to sort. 
2. On the Data tab, in the Sort & Filter group, click Sort. 

 

3. In the Sort dialog box, under Column, in the Sort by box, select the column that you want to sort. 

 

4. Under Sort On, select Cell Color, Font Color, or Cell Icon. 

 

5. Under Order, click the arrow next to the button and then, depending on the type of format, select a cell color, font 
color, or cell icon. 

6. Next, select how you want to sort. Do one of the following: 
▪ To move the cell color, font color, or icon to the top or to the left, select On Top for a column sort, and On 

Left for a row sort. 
▪ To move the cell color, font color, or icon to the bottom or to the right, select On Bottom for a column 

sort, and On Right for a row sort. 

Note: There is no default cell color, font color, or icon sort order. You must define the order that you want for each 

sort operation. 

7. To specify the next cell color, font color, or icon to sort by, click Add Level, and then repeat steps three through 
five. 

Make sure that you select the same column in the Then by box and that you make the same selection under Order. 
Keep repeating for each additional cell color, font color, or icon that you want included in the sort. 
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Filter data in a range or table 

Filter a range of data 

1. Select any cell within the range. 

2. Select Data > Filter. 

 

3. Select the column header arrow  . 

4. Select Text Filters or Number Filters, and then select a comparison, like Between. 

 

5. Enter the filter criteria and select OK. 
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Filter data in a table 

When you put your data in a table, filter controls are automatically added to the table headers. 

 

 

1. Select the column header arrow  for the column you want to filter. 

2. Uncheck (Select All)  and select the boxes you want to show. 

3. Click OK. 

 

The column header arrow  changes to a  Filter  icon. Select this icon to change or 

clear the filter. 

 

 

 

 

 
 
 
  

Charts 
 

 
Create a Chart 

1. Select the data you want to use for your chart. 

2. Click Insert > Recommended Charts. 

 

3. On the Recommended Charts tab, scroll through the list of charts that Excel recommends for your data, and 

click any chart to see how your data will look. 

https://support.microsoft.com/en-us/office/create-and-format-tables-e81aa349-b006-4f8a-9806-5af9df0ac664
https://support.microsoft.com/en-us/office/select-data-for-a-chart-5fca57b7-8c52-4e09-979a-631085113862
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Tip: If you don’t see a chart you l ke, cl ck All Charts to see all available chart types. 

4. When you find the chart you like, click it > OK. 

5. Use the Chart Elements, Chart Styles, and Chart Filters buttons next to the upper-right corner of the chart to 

add chart elements like axis titles or data labels, customize the look of your chart, or change the data that’s shown 

in the chart. 

 

6. To access additional design and formatting features, click anywhere in the chart to add the Chart Tools to the 

ribbon, and then click the options you want on the Design and Format tabs. 

 

https://support.microsoft.com/en-us/office/add-or-remove-titles-in-a-chart-4cf3c009-1482-4908-922a-997c32ea8250
https://support.microsoft.com/en-us/office/add-or-remove-data-labels-in-a-chart-884bf2f1-2e29-454e-8b42-f467c9f4eb2d
https://support.microsoft.com/en-us/office/change-the-color-or-style-of-a-chart-in-office-f4db3f23-f5a1-4b30-abb3-62e8c2c33d9b
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Add a Pie Chart 

1. In your spreadsheet, select the data to use for your pie chart. 

For more information about how pie chart data should be arranged, see Data for pie charts. 

2. Click Insert > Insert Pie or Doughnut Chart, and then pick the chart you want. 

 

3. Click the chart and then click the icons next to the chart to add finishing touches: 

▪ To show, hide, or format things like axis titles or data labels, click Chart Elements  . 

▪ To quickly change the color or style of the chart, use the Chart Styles  . 

▪ To show or hide data in your chart click Chart Filters  . 

 

 

https://support.microsoft.com/en-us/office/select-data-for-a-chart-5fca57b7-8c52-4e09-979a-631085113862
https://support.microsoft.com/en-us/office/add-a-pie-chart-1a5f08ae-ba40-46f2-9ed0-ff84873b7863#__learn_more_about
https://support.microsoft.com/en-us/office/add-or-remove-titles-in-a-chart-4cf3c009-1482-4908-922a-997c32ea8250
https://support.microsoft.com/en-us/office/add-or-remove-data-labels-in-a-chart-884bf2f1-2e29-454e-8b42-f467c9f4eb2d
https://support.microsoft.com/en-us/office/change-the-color-or-style-of-a-chart-in-office-f4db3f23-f5a1-4b30-abb3-62e8c2c33d9b
https://support.microsoft.com/en-us/office/change-the-data-series-in-a-chart-30b55a30-1c2e-42d5-8ed1-3cc3ffb68036
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Create a waterfall chart 

1. Select your data. 

 

2. Click Insert > Insert Waterfall or Stock chart > Waterfall. 

 

You can also use the All Charts tab in Recommended Charts to create a waterfall chart. 

Tip: Use the Design and Format tabs to customize the look of your chart. If you don't see these tabs, click 
anywhere in the waterfall chart to add the Chart Tools to the ribbon. 

 

Start subtotals or totals from the horizontal axis 

If your data includes values that are considered Subtotals or Totals, such as Net Income, you can set those values so 

they start on the horizontal axis at zero and don't "float". 

▪ Double-click a data point to open the Format Data Point task pane, and check the Set as total box. 

 

Note: If you single-click the column, you'll select the data series and not the data point. 

To make the column "float" again, uncheck the Set as total box. 

Tip: You can also set totals by right-clicking on a data point and picking Set as Total from the shortcut menu. 
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Show or hide connector lines 

Connector lines connect the end of each column to the beginning of the next column, helping show the flow of the data in 

the chart. 

▪ To hide the connector lines, right-click a data series to open the Format Data Series task pane, and uncheck 

the Show connector lines box. To show the lines again, check the Show connector lines box. 

 

 

Change Axis labels on a Chart 

1. Click each cell in the worksheet that contains the label text you want to change. 

2. Type the text you want in each cell, and press Enter. 

 

As you change the text in the cells, the labels in the chart are updated. 
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To keep the text in the source data on the worksheet the way it is, and just create custom labels, you can enter new label 

text that's independent of the worksheet data: 

1. Right-click the category labels you want to change, and click Select Data. 

 

2. In the Horizontal (Category) Axis Labels box, click Edit. 

3. In the Axis label range box, enter the labels you want to use, separated by commas. 

 

For example, type Quarter 1,Quarter 2,Quarter 3,Quarter 4. 
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Change the format of text and numbers in labels 

To change the format of text in category axis labels: 

1. Right-click the category axis labels you want to format, and click Font. 
2. On the Font tab, choose the formatting options you want. 
3. On the Character Spacing tab, choose the spacing options you want. 

 
To change the format of numbers on the value axis: 

1. Right-click the value axis labels you want to format. 
2. Click Format Axis. 
3. In the Format Axis pane, click Number. 
4. Choose the number format options you want. 

 

If the number format you choose uses decimal places, you can specify them in the Decimal places box. 

5. To keep numbers linked to the worksheet cells, check the Linked to source box. 

Note: Before you format numbers as percentages, make sure that the numbers shown on the chart have been calculated 

as percentages in the worksheet, or are shown in decimal format like 0.1. To calculate percentages on the worksheet, 

divide the amount by the total. For example, if you enter =10/100 and format the result 0.1 as a percentage, the number is 

correctly shown as 10%. 

Tip: An axis label is different from an axis title, which you can add to describe what's shown on the axis. Axis titles 

are not automatically shown in a chart.. 
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Create a PivotTable to analyze worksheet data 
1. Select the cells you want to create a PivotTable from. 

Note:  Your data shouldn't have any empty rows or columns. It must have only a single-row heading. 
2. Select Insert > PivotTable. 

         

3. Under Choose the data that you want to analyze, select Select a table or range.  

         

4. In Table/Range, verify the cell range. 
5. Under Choose where you want the PivotTable report to be placed, select New worksheet to place the 

PivotTable in a new worksheet or Existing worksheet and then select the location you want the PivotTable to 
appear. 

6. Select OK. 

Building out your PivotTable 

1. To add a field to your PivotTable, select the field name checkbox in 
the PivotTables Fields pane. 
 

2. To move a field from one area to another, drag the field to the target area  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Cl ck to watch the “Create a P vot Table” V deo 

For more information, please refer to the Microsoft training resource page HERE 

https://www.microsoft.com/en-us/videoplayer/embed/RWfyHX?pid=ocpVideo0-innerdiv-oneplayer&postJsllMsg=true&maskLevel=20&market=en-us
https://support.microsoft.com/en-us/office/video-what-is-microsoft-teams-422bf3aa-9ae8-46f1-83a2-e65720e1a34d?wt.mc_id=otc_microsoft_teams

